Saturday, 21 September 2013

E21: Front indicators - a common problem?

Is your front corner-indicator not working, but the bulb and fuse are fine?

Mine wasn't and it turned out to be the metal live-clip that sits against the bottom of the bulb. Not the best of designs, connection is lost to the bulb if the clip is bent back slightly, causing the indicator to fail intermittently [denoted by faster clicking of the turning-signal]. The clip having a little corrosion or crud on it is also enough to stop the bulb getting a signal.

A quick clean up with emery-cloth and a slight bend forwards so it sits tight on the bulb was enough to get mine working solidly again. This could be a common problem, especially in the UK and Europe where grime gets pushed everywhere in an E21, so if your fuse and bulb appear fine, but the indicator won't work, you can bet it's the live-clip.


PROCESS:

1. Dis-connect the corner indicator wiring by sliding apart the plastic-clip located behind the headlamp under the bonnet and push it through the hole to the outside of the wing.

2. Remove the two crosshead screws holding the corner-indicator lens and lift the lens off.

3. Remove the two crosshead screws holding the indicator-housing to the wing. The housing should now slide forwards and clear the wing.

4. Use nose-pliers to remove the metal live-clip from where it sits in the plastic-housing.

5. Bend the prong [denoted by the arrow] in towards the other prong, bringing the flat-edge down.

6. Clean up the face of the prong and the metal-contact on the bulb with emery-cloth.

7. Replace the live-clip to the plastic-housing and reverse Steps 1-3 to re-fit.

No comments:

Post a comment